US West (Chandler) [neo-us2] - Service Advisory
Incident Report for SAP Business Technology Platform
Resolved
Service has been restored as of approximately 12:12 UTC on 24 Mar 2021.
Posted Mar 24, 2021 - 13:12 UTC
Update
Service is restored since 12:12 UTC on 24 Mar 2021 and we are monitoring to ensure stability.
Posted Mar 24, 2021 - 12:41 UTC
Identified
Since approximately 11:39 UTC on 24 Mar 2021, customers may have experienced a disruption on the SAP Business Technology Platform. Engineers are working to restore service and updates will be provided as events warrant.

Regions:
- US West (Chandler) [neo-us2]

Impact:
- Forms by Adobe is unavailable
Posted Mar 24, 2021 - 12:16 UTC
This incident affected: US West (Chandler) [neo-us2] (All Advisories [neo-us2]).